Back
Resolved

Steam had global problem.

Started 6 May at 09:51pm CEST.

steampowered.com
Created

Hello, steam has from 4 p.m. US time / European time from 8 p.m. The problem is RESOLVED

Posted 6 May at 09:51pm CEST.